[Pz-LkC][2.0.3]リンクをカード形式で表示するプラグイン更新。404エラー時の処理変更など

リンクをカード形式で表示するWordPressプラグイン「Pz-LinkCard」。

最新版ver2.0.3を公式プラグインディレクトリで公開しました。

ver2.0.2→ver2.0.3修正点

2017年8月8日に公開したver2.0.2からのバージョンアップです。

404エラーのときでもリンクを有効にする設定を追加しました

Ver2.0.0で、リンク先が「403」「404」「410」のときにリンクを無効にする機能を追加していました。

サイトによってはPz-LinkCardからは「404 Not Found」で返ってきても、PCで見るとちゃんと見られるサイトがあるようです。

そのため、「設定」→「Pz カード設定」の「リンク先のチェック」の項目に「エラーのときにリンクしない」という項目を追加しました。

内部リンクの抜粋が取得できていなかったのを修正しました

WordPressの投稿には記事とは別に「抜粋」というのを設定できます。

通常のテーマでは表示されませんが、テーマによっては抜粋表示に使用されたりします。

「内部リンク」の設定に「抜粋文が設定されている投稿はそちらを優先する」という設定がありますが、正しく動作していなかったため修正しました。

外部リンクのサムネイル取得が出来なくなる不具合を修正しました

外部リンクのサムネイルを「直接取得」とした場合には、OGPやTwitterカードで設定されている画像をキャッシュしています。

設定画面で「変更を保存」ボタンを押すと、キャッシュのディレクトリが上手く設定されず、リンク先のアイキャッチ画像が表示されなくなる不具合を修正しました。

その他

お気づきの点などありましたら、コメント欄や、ツイッターアカウント「ぽぽろん@ぽぽづれ。(@popo68k)」もしくは「ぽぽづれ。(@popozure)」までご報告ください。

では、この辺で。(^-^)o

広告

『[Pz-LkC][2.0.3]リンクをカード形式で表示するプラグイン更新。404エラー時の処理変更など』へのコメント

  1. 名前:AndroPlus 投稿日:2017/10/03(火) 11:26:06 ID:d07b30e77 返信

    更新履歴でModifiedがModefiedになってますよ

    • 名前:ぽぽろん 投稿日:2017/10/03(火) 19:12:12 ID:cab16b383 返信

      AndroPlusさん、コメントありがとうございます。

      本日公開のVer2.0.4.1でReadme.txtを修正しました。

  2. 名前:ESD 投稿日:2017/09/24(日) 00:26:28 ID:918877e6f 返信

    お世話になっております。
    以前のコメント以来色々ありまして、サーバー移転をしつつテーマの変更などをいた結果、500エラーになる症状が再現できなくなりました。
    情報提供できず申し訳ありません…。

    とりあえず現環境では、
    外部リンク>サムネイル>直接取得できない場合、WebAPIを利用する
    と設定した状態で500エラーは出ていません。
    以前のテーマなどとの干渉だったかと思います。
    しかし相変わらずアメブロのサムネイルは404と書いた画像が表示されるだけです。これはアメブロ側の仕様によるものなんでしょうか?

    もう一点、AMPについてです。
    Google Search Consoleに「重大な問題のある AMP ページ」としてメッセージが届いていて、内容を確認したところ、エラーの出ているページ全てに以下の警告が出ていました。

    「AMP タグに無効なレイアウト プロパティがある(重大な問題)」
    「レイアウト「FIXED_HEIGHT」で、タグ「amp-img」の属性「width」の値「16」が無効です。属性「width」に値「auto」を設定してください。」

    ページをテストしたところ、Pz-LinkCardのファビコン取得について、
    $favicon = ”;
    となっているのが、グーグル様はお気に召さないようでした。
    現在はプラグインの編集で width=auto と書き換えてエラー回避しています。
    こちらは他の対策などあるんでしょうか…?

    よろしくお願いします。

    • 名前:ESD 投稿日:2017/09/24(日) 00:29:19 ID:918877e6f 返信

      該当箇所
      img class=”lkc-favicon” src=”‘.$favicon_url.'” alt=”” width=16 height=16 /
      です。

    • 名前:ぽぽろん 投稿日:2017/09/26(火) 21:27:31 ID:02e3fec1b 返信

      ESDさん、ご利用&コメントありがとうございます。

      サーバーエラーは解消されたとのことで良かったです。

      アメブロのサムネに関しては詳しくは分かりませんが、ブラウザ以外のアクセスには404を返すのかも知れません。URLを教えていただけると調査できるかも知れません。

      AMPに関してですが、「設定」→「Pz カード設定」→「詳しい人用」のところにある「Google AMP」にチェックが入っていると、URLが /AMP で終わる場合に簡易表示に切り替えます。簡易表示の場合にはファビコンは表示させないようにしていますが、こちらにチェックは入っておりますでしょうか。

      • 名前:ESD 投稿日:2017/09/27(水) 14:13:11 ID:8115d0074 返信

        お世話になっております。

        サムネが表示されないアメブロは、例えば次のサイトなどです。
        h ttp://ameblo.jp/kyohro/
        h ttp://ameblo.jp/yodo-dashigumi/
        (最初のhのあとにスペース入れてあります)

        AMPについては、
        「設定」→「Pz カード設定」→「詳しい人用」→「Google AMP」
        にチェックを入れている状態です。
        AMPページを表示すると、リンク先のファビコンとサムネが画面幅いっぱいに表示されます。

        • 名前:ぽぽろん 投稿日:2017/09/27(水) 18:27:04 ID:af33921fe 返信

          アメブロはSSL化されているため、「http」では無く、「https」でURLを指定することでエラーは回避できると思います。
          なお、アイキャッチ(サムネイル)はOGPやTwitterカードの形式で指定されていないため取得できません。

      • 名前:ESD 投稿日:2017/09/27(水) 14:29:41 ID:8115d0074 返信

        AMPについて原因がわかったかもしれません。
        使っているテーマでは、AMPページを表示する際のURL末尾が「?amp=1」でした。

        pz-linkcard.phpの687行目で
         preg_match(‘{/amp/?$}i’,

         preg_match(‘{?amp=1/?$}i’,
        と書き換えたら簡易版のリンクカードが表示されるようになりました。

        • 名前:ぽぽろん 投稿日:2017/09/27(水) 18:28:49 ID:af33921fe 返信

          URLの末尾がAMP以外のパターンも有り得るのですね。少し確認したみたところ、で指定したURLがAMPのページっぽいので今の判断では対応できない場合も多そうです。

          「今自分がAMPで表示されているかどうか」をWordPress関数とかで判断できるのなら幅広く対応できると思うのですが、とりあえずその対応でお願いします。

          • 名前:ESD 投稿日:2017/09/28(木) 22:43:16 ID:6b7e037e8 返信

            ありがとうございます。
            やっぱり現状では「URLの末尾にAMPっぽいものがついているかどうか」でしか分岐条件作れないのですね。
            とりあえずしばらくは現在のテーマを使い続けるので、この対応で過ごしたいと思います。
            もし気が向いたら、「詳しい人用」→「Google AMP」の項目でAMP対応するかどうかのチェックの他に、AMPページのURL末尾が「/amp」なのか「?amp=1」なのかというラジオボタンを付けて対応してくれたら素敵だなーなんて思います。
            これからも応援してます!

            • 名前:ぽぽろん 投稿日:2017/10/03(火) 19:22:40 ID:cab16b383 返信

              本日公開のVer2.0.4.1にて対応しました。
              ちなみに何のテーマを使っているか参考までに教えていただけると助かります。

              • 名前:ESD 投稿日:2017/10/04(水) 03:14:21 ID:952e12b4a 返信

                対応ありがとうございます!
                使わせてもらっているテーマはこちらです。

                Celtis_s テーマ
                https://celtislab.net/wordpress-theme-celtis_s/

                ?amp=1にしている理由がこちらにあります。

                https://celtislab.net/archives/20170414/celtis_s-amp/

                あとGoogle AMPの項目の説明が「アクセスされたURLの末尾が「/amp」の場合、簡易表示に切り替える。」のままなので「/amp/」と「/?amp=1」もいつか仲間に入れてやってください^^

                • 名前:ぽぽろん 投稿日:2017/10/04(水) 19:32:11 ID:f132ac878

                  テーマ、教えていただいてありがとうございます。

                  一応、設定画面の表記上は「末尾が『/amp』」のみなのですが、「末尾が『/amp/』」も定義してあります。あと、昨日公開したVer2.0.4.1では「末尾が『/?amp=1』」も定義しました。(たぶんちゃんと反応してくれると思いますが、ダメだったら教えてください!)

                  [追記]
                  よくよく読んでみたら説明文を実装に合わせようという提案でしたね。文字数と相談しながら変更したいと思います。

  3. 名前:田中 投稿日:2017/09/11(月) 21:13:58 ID:9fdcb3203 返信

    お世話になります。

    ワードプレスで最新バージョン2.0.3を利用しているのですが、記事のタイトルや抜粋がすべてブログトップページとなってしまいます。

    設定も初期設定のままです。当サイトはssl化はしておりません。

    以上宜しくお願い致します。

    • 名前:ぽぽろん 投稿日:2017/09/14(木) 20:53:28 ID:ee7fa3f2b 返信

      田中さん、ご利用&コメントありがとうございます。

      内部リンクについては、WordPressの機能を使用してURLから記事IDを取得して、それをもとに記事内容を取得しています。
      URLを変更するプラグイン等(例えばURLの最後に .html を付ける等)を使用している場合、うまく取得できない場合があります。

      サイトURLを教えていただけると調査したりお手伝いできるかと思います。

  4. 名前:ESD 投稿日:2017/08/20(日) 21:46:32 ID:54ea32fb0 返信

    いつもありがたく使わせていただいてます。
    アメブロへのリンクは以前からサムネイル取得ができなかったのですが、最新のバージョンでは
    「設定>外部リンク>サムネイル」で「直接取得できない場合、webAPIを取得する」にしている状態でアメブロへのリンクカードを埋め込んでいると、その記事のページ自体が500エラーになって表示されなくなっていました。
    使い方が間違っているのかもしれませんが、何か解決法などありますでしょうか?

    • 名前:ぽぽろん 投稿日:2017/08/30(水) 21:51:53 ID:d67cb6783 返信

      ESDさん、ご利用&コメントありがとうございます。

      こちらでは起きていない現象なので、出来たらエラーになってしまうアメブロのURLなどを教えていただけると対応できるかも知れませんのでよろしくお願いします。
      おそらくはアイキャッチ画像を取得しに行っているときに何かかしら不具合があるのだと思います。