[Pz-LkC][2.4.0]リンクをカード形式で表示するプラグイン更新。エラーが表示される不具合修正。

Pz-LinkCard

リンクをカード形式で表示するWordPressプラグイン「Pz-LinkCard」。

最新版ver2.4.0を公式プラグインディレクトリで公開しました。

ver2.3.1→ver2.4.0修正点

2019年11月17日に公開したver2.3.1からのバージョンアップです。

作者都合により1年間更新が出来ていませんでした。

WordPress最新版での動作確認

WordPressの以下のバージョンでの動作を確認しました。

  • WordPress 5.4.2
  • WordPress 5.5
  • WordPress 5.5.3

記事では無いページでURL無効のエラーが表示される不具合修正

記事ページでショートコードを記述した際、URLの指定方法などが正しく無い場合に管理画面へエラーが表示されます。

このエラーが記事ページ以外に表示されてしまい、修正できない状態となることがありましたので、記事ページ以外でのエラー表示を抑制しました。

※作者環境では発生しない症状なので、今後も発生するようであれば調査いたします。

マルチサイトの判定においてエラーが表示される不具合修正

マルチサイトの判定においてエラーが表示されていたのを抑制しました。

おそらく長い事表示されていたと思われます。

Warning: Use of undefined constant is_main_site – assumed ‘is_main_site’ (this will throw an Error in a future version of PHP) in /home/********/********.**.**/public_html/wp-content/plugins/pz-linkcard/pz-linkcard.php on line 902

※作者環境では発生しない症状なので、今後も発生するようであれば調査いたします。

既知の不具合

「設定」→「Pz カード設定」を開いたあと、設定のタブがありますが、これをクリックしても動作しない不具合が一部サイトで発生しています。

解決方法が無いわけでは無いのですが、原因が分かっておらず根本的な解決にいたっておりません。

「WordPressの管理画面において、jQueryが使用できない状態が起こっている」のが原因と思われますが、作者の環境で再現ができておりません。

通常の使用方法において、jQueryが読み込まれない状況を作る設定などをご存じの方は教えていただけると助かります。

その他

お気づきの点などありましたら、コメント欄や、ツイッターアカウント「ぽぽろん@ぽぽづれ。(@popo68k)」もしくは「ぽぽづれ。(@popozure)」までご報告ください。

では、この辺で。(^-^)o

コメント

タイトルとURLをコピーしました